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1.IRSA introduction 

1.1 introduction 

IRSA software is developed by lab of remote sensing image processing in 

Institute of Remote Sensing and Digital Earth (RADI), CAS. The platform for IRSA 

is PC. It can process multiple data and has the common functions for image 

processing. It also provides special functions for initial image data processing and 

professional functions.  

The platform for IRSA is PC. It can process multiple data and other 

supplementary data and has the common functions for image processing. It also 

provides special functions for initial image data processing and professional 

functions.  

1.2 Main Interface 

The main interface of IRSA is comprised by 7 main modules: Viewer, Process, 

Recovery, Rectify, Mosaic, Fusion and Classification.  

 



1.3 IRSA Modules Introduction 

Viewer: Viewer module is used for displaying image and related information. It 

can process all supported file formats. It can view huge mass RS image(over 4GB) 

fast with few RAM. 

Processing: Execute geometric transformation, enhancement, filter and basic 

image transformation from file to file. These are the effective tools for image data 

processing and analysis. 

Recovery: Rectify images to remove the image regression caused by imaging or 

exterior conditions. This module includes: Strip Noise Removal, Motion Blur 

Recovery, Haze Removal, MTF correction and radiometric correction.  

Geocorrect: It is the process to project image to plane surface to make it in accordance with 

geographic projection system and add cartographic coordinates system. 

Mosaic: This module provides auto-mosaic based on geo-information with friendly interface 

and easy operation. The well designed algorithm ensures the high efficiency. It contains 

auto-mosaic and manual match mosaic. 

Fusion: Spatially match the images of the same place from different sensors and 

use some algorithm to combine all information of different images to generate new 

image. 

Classification: Divide pixels of image into different classes according to their 

characteristics. 

2.Viewer 

Viewer module is used for displaying image and related information. It can 

process all supported file formats. It can view huge mass RS image(over 4GB) fast 

with few RAM. Besides, it supports the overlapping display of several images with 



geo-reference and raster with vector. All geo-information can be displayed and 

distance or area can be measured directly. 

 

2.1 Open Raster Image File 

The follows are the File bar and tool bar. 

 

Select “File”→ “Open（O）” or click  to open file selection window. After 

selection, click OK. If it is the supported file format of IRSA , View Creation dialog 

pops up:  

 

 



The definition of each part is introduced below: 

(1) New 

When selected this button, a new View will open to load image. 

(2) Add to existing View 

When selected this button, the opening image will load to the existing View as a 

layer. Select the existing Views from the list box. 

(3) Display Mode 

There are 3 display modes: Gray Image, RGB True Color, Pseudo Color. Gray 

image displays one band of image; RGB image select 3 bands as the R, G and B 

band to select; pseudo image displays one band, the pixel value maps to a color 

table to make the image colorful. 

(4) Dataset 

Select the image dataset to display. Generally, one dataset stands for one image 

and there is one dataset in one image, there is also one file containing several 

datasets, like HDF file of Modis images. Once user opens a file, the dataset 

generates. For the management of dataset, please go to section 2.2.  Select the 

open dataset from the combo box.  

(5) Band Selection 

Select the band in dataset that want to display. For gray mode or pseudo mode, 

only need select one band; for RGB mode, three bands need select. All bands are 

displayed in combo box for selection.  

2.2 Catalog 

One dataset stands for one image and there is one dataset in one image, there is 

also one file containing several datasets, like HDF file of Modis images. The open 

datasets are managed by file manager. Click “View” -> “File Manager” and the 

interface is shown below:  



 

The data in file manager is organized in tree construction, the root for the tree is 

the name of the dataset, commonly same with file name; the sub-node is the bands 

containing in the dataset.  

 

(1) Open & Close Dataset  

Once a file is opened, a new dataset is added into file manager. The new View 

can be displayed from these datasets. When View closed, datasets still open and can 

load in new View again. Close datasets following these steps:  

Step 1: Move the mouse to the node of the dataset that want to close; 

Step 2: Right click mouse to open context menu: 

 

Step 3: Click Close. The selected dataset is closed. If there are View layers from this 

dataset, a window will pop up to ask whether close the corresponding layer 

in View. Select OK to delete the layer in View and close the dataset.  

(2) View Data Attributes  

Click “View” -> “File Attribute” or  to pop up attribute window, shown 

below: 



 

 In this window ,the attributes of selected dataset are displayed, including file information, 

band information, projection information, geographic information. 

(3) View Pixel Value 

View the pixel values in all bands. Right click mouse on dataset to open context 

menu, click “View Pixel Value” and the dialog shown below pop up: 



 

The number in first row and column of the table start both from 0, showing the 

row and column number of upper left corner of image, and other units display the 

corresponding pixel values; the band selection combo box contains all bands list, 

select the band and the table will update to the selected band value.  

 

2.3 Layer Management 

Multi-images can be displayed in one View, and each image is called a layer. The is a 

overlapping sequence from top to bottom in the direction vertical to screen, called Z order. The 

upper layer will cover the lower layer. The sequence can be changed by adjusting Z order. Layer 

Create, Layer Delete and Z Order Adjustment can all be operated in layer manager, shown below:  



 

In the middle of layer manager, there are several bar, each of witch matches with one layer, 

piling follow the Z order; the title of bar is the name of the layer; click title and the layer is 

selected and the bar will unfold just like the first layer shown in the picture above, here the color 

mode and band combination can be set; 

2.4 Image View 

(1) View Toolbar 

 After image loading, use the tools on tool bar to operate the image, the bar is shown below: 

 

 

(2) Use Overview to Explore 

Use Overview to navigate. Click  or select “View”→ “Overview” to open Overview 

window shown below: 

 



The red rectangle in Overview stands for the range displaying in View. Move the image, and 

the red rectangle changes correspondingly.  

(3) Multi-windows GeoLink View  

 For this function, two or more Views need open, and there is geo-overlapping area for these 

Views. If these two conditions satisfied, operate the following steps to GeoLink Views: 

Step 1: Ensure that the linking View is under Geo-Code mode; 

Step 2: Right click in one of the Views and open the context menu like this: 

 

 

the “GeoLink” is activated, click to open the GeoLink dialog: 

 

 

All View that can be linked with main View are listed in the combo box. Select and click OK to 

link. 

Step 3: After linking, when explore in the main View, the linking View changes correspondingly, 

ensuring the same area. 

Step 4: One View can link to multiple Views, just repeat the step 2. 

Step 5: For canceling GeoLink, right click on main View and open menu: 

 

If it is in GeoLink, the “Link Cancel” is activated, click to cancel. 

 



(4) Display Multi-Layer with Swipe and Flicker 

 These two special display modes can display the upper and lower layers 

alternating. 

a.Swipe:  

When there are more than 2 layers in View, select “View” -> “Swipe” to popup 

the following dialog: 

 

 

Select “Scroll” in “Swipe Mode”, the “Swipe Direction” has 3 directions: 

 Vertical(Vert.)－Swipe up-and-down to display the two layers; 

 Horizontal(Hor.) －Swipe left-to-right to display the two layers; 

 Free－Swipe in both directions to display; 

b.Flicker:  

This mode is to display two layers alternating, adaptable for look up the 

difference between two layers. There are manual mode and auto mode 

 Manual: Click in the View to switch to lower layer and upper layer hides; 

loose mouse, lower one hides and upper one displays. Click repeat to flicker. 

 Auto: Automatically alternating display two layers following the set speed. 

 

2.5 AOI Tool 

AOI layer includes point, polyline, polygon/rectangle, ellipse/circle and text etc. 

Using AOI tool can generate, edit, draw, and save these objects.  

(1) Generate AOI 



 Point: Select “AOI” -> “Point” or click . Then user can click on the View to add a 

point. 

 Polyline: Select “AOI” -> “Polyline” or click . Then user can click on the View to 

add the first node of the ployline. Move mouse to draw the trace, and then click to add the 

second node. Repeat this to draw all nodes. Double click to end polyline drawing, and the 

new polyline is selected. 

 Polygon: Select “AOI” -> “Polygon” or click . Then user can click on the View to 

add the first node of the polygon. Move mouse to draw the trace, and then click to add the 

second node. Repeat this to draw all nodes. Double click to end polygon drawing, and the 

new polygon is selected.  

 Ellipse: Select “AOI” -> “Ellipse” or click . Then user can click on the View to add 

the upper left corner of circum rectangle of ellipse. Do not loose mouse and drag. Release 

mouse to end ellipse drawing, and the new ellipse is selected.  

 Rectangle: Select “AOI” -> “Rectangle” or click . Then user can click on the View 

to add the upper left corner of rectangle. Do not loose mouse and drag. Release mouse to 

end rectangle drawing, and the new rectangle is selected.  

 (2) AOI Measure Tool 

 When there is AOI graph selected, the area, perimeter and distance of AOI can be 

measured. The steps are: 

Step1: Draw AOI and select it. It the graph is polygon, rectangle, ellipse or polyline, 

the measure tool can be used. 

Step 2: Select “Feature Extraction” -> “Measure” or right click on AOI to open context 

menu, select “Measure” to open the measuring result dialog: 



 

3.GeoCorrect 

Function: Geometric correction is the process of projection image data into plane 

surface to accord it with cartographic projection system; the process is called 

geo-reference. Because all cartographic projection systems obey some cartographic 

coordinate system, geometric correction includes geo-reference.  

Step:  

Step 1:  Open the GeoCorrect module 

 

Then you can find the follows: 



 

Step 2:   Open distorted image. 

File Name:   Click Browse… to open File Open dialog to select distorted 

image. 

Step 3:    Open reference image. 

The use is the same as the distorted image open. 

Step 4:  Open GCP list. 

      When the GCP values are needed, click this button to popup the following 

window. When enter in the main program, this window is open.. 

 

Step 5:   GCP select. 

Add GCP 

The mouse changes into Add GPC status after click it, click left button in selected 

location to get one GCP. 



Choose or Move GCPs 

Compute Residuals 

Click it to calculate GCPs Residuals. 

GCP ID: the node for GCP。 

Color : Click left button on color column to pop up color list to select one color.  

 Right click on GCP list to popup “Delete GCP” menu and 

delete the selected GCP. 

Double click on selected GCP in GCP list, orientation window will move to the 

location of this GCP. 

Click “Move GCPs” icon on tool bar, use mouse to drag the selected point to 

modify its location. Or input new coordinate values in GCP list and the GCP will 

move the corresponding location. 

Step 6:   Resample 

.when you select enough GCP, you can click “Tools-Geometric Correction”,you 

can find that. 



 

After setting the Output Image, Resample, Image Resolution,click “Run”,you 

will get the result. 

4.Mosaic 

Functions: Mosaic two or more digital images to one united new image by the 

process of geometric mosaic, color adjustment and overlap exclusion. 

This function acquires that images have geographic information and the 

projection, ellipsoid, datum level and resolution between images must keep in 

accordance with each other. It supports a maximum of 1024 images to mosaic at the 

same time. 

 



 

Steps: 

Step 1：Click File->Open Image in menu or click  on toolbar，pop up the Add 

Images window;  

 

Step2: Click Browse to open the appointed image; 

Step3: Click OK to finish image adding; 

 

Notices: 

(1)The bands order can be reset in the Correspondent NewImage Band list, then 

click OK 



 

(2) Redo step 1 to 3 to continue adding images 

(3) Select show OverView Image? Can read the contents of images and show 

them in the main program. 



 

Step 4: Click  in toolbar to switch to image mode 

 

Step 5: Select the image to edit in Image Mosaic window by mouse, click  on 

toolbar to move image to upper layer, while click   to move it to 

lower layer, click   to move the image to top layer，while click   



to bottom layer。 

Step 6: Click  to switch to intersection mode and than the intersection area 

of images can be edited. 

 

Step 7: Click   to generate a cut-line in the geometric center of the selected 

overlapping area. 

 

1) Click  to delete the cut-line of the selected overlapping area. 

2) Click  to generate all cut-lines for each overlapping area. 

3) Click  and the mouse changes into , users can draw one cut-line in 

overlapping area, double click mouse to finish. 

Step 8: Click Overlap -> Set Overlap Function or click  to pop up 

overlapping area adjustment window; 

(1) When the overlap type is without cut-line, the function below can be set: 

 



 

 Overlap：Use the image of lower layer to overlap the upper layer in overlapping 

area. 

 Average：Use the average of overlapping area. 

 Maximum：Use the maximum of all image layers in overlapping area. 

 Minimum：Use the minimum of all image layers in overlapping area. 

 

（2）When there is a cut-line in overlapping area, The functions can be chosen 

are: 

 



 

 Only Mosaic：do not feathering in overlapping area 

 Mosaic and Feather：feather in overlapping area and set the feathering radius 

pixel in blank manually. 

 Same Setting: Choose the checkbox to apply the same setting to all overlapping 

areas. 

Step 9：Click  to switch into output mode，and overlapping areas can be edited； 

 

4) Click  to define the output area with mouse in the main operation window. 



 

5) Click  to delete the customized output area. 

6) Click  to set output parameters. 



 

Click Browse… to set the output file name.  

Output Background Color：User can set the background color of invalid output 

area.  

Data Type：User can set the output data type. 

Output Resolution：User can modify the resolution of the output image. 

Match Options： 

 No Color Match：Do not operate light balance adjustment to image 

 Entire Match：Match the whole image 

 Intersection Match：Match in overlapping areas. 

Ignore Background Color：Pick up this option to ignore the invalid area 

Output Map Coordinate：User can identify the final mosaic area with keyboard 

input 

Click OK to finish and close the Output Option window. 

Step 10：Click  or Mosaic>run… in menu to run mosaic. 

5. Fusion 

Fusion module function: fuse the images of the same place from different sensors 



to enhance image, the processed image have the multi-spectrum information and 

better spatial resolution 

 

 

5.1 Fusion based on RGB-HIS transformation 

Function: In colorimetry, three base color comprise of the color information，it 

can also be described by intensity and chroma. The intensity is the feeling of 

brightness of human’s eyes that caused by light, and it is the direct proportion to 

object reflection ratio, while chroma can be divided into hue and saturation. Hue is the 

main spectrum wavelength or average wavelength, saturation is the light or dark 

extent of color. IHS model of color information is quite suitable for image processing 

of apperceiving color characteristics with human visual system. 

Notice: IHS transformation fusion replaces component I of high resolution and 

Multispectral images after IHS transformation and than process IHS inverse 

transformation to acquire the fusion image. Compared to original image, the spatial 

resolution has improved. This fusion mode is often used for images of feature 

enhancement and obvious feature difference to improve the special resolution of 

Multispectral image, but it may cause the spectrum distortion of the result.  

 



 

Steps:  

Step 1: Click the button Browse… of Multispectral image input to open file; 

Step 2: The default processing bands are the first three bands of image, user can click 

the band list to set the bands; 

Step 3: Click the button Browse…. Of high resolution image input to open file; 

Step 4: The default band is the first band of image, it can also be changed by clicking 

band list button; 

Step 5: Choose the resample method, the default is bilinear interpolation; 

Step 6: Click Browse button of output image to choose the path and set the file name 

and file type; 

Step 7: Band Description: this edit box is editable and receives the default value. It 

can also add extra image information; the description will be shown in the 



notice of new paths; 

Step 8: Click Run, the main interface disappear and pop up the progress bar. When the 

program finish, the main interface will recover and pop up the dialog of 

success.  

5.2 Fusion based on PCA 

Function: PCA is also called principal component analysis or K-L transformation, 

which is the multi-dimension orthogonal linear transformation base on statistics. The 

purpose for PCA transformation is not decreasing the affection of random noise or 

compressing data but keeping the statistics independent of each band of 

Multispectral image, then process each band to implement pixel-level fusion, which 

is convenient for data more than three bands. 

Notice:  

PCA transformation fusion replaces the first component of Multispectral image 

after PCA transformation with high resolution image, then process the PCA inverse 

transformation to acquire fusion image. This fusion mode is often used for the 

dynamic analysis of images from different sensors or multi-temporal images. This 

transformation can remove noise and add special information of high resolution 

image. But it may not keep the original spectrum components well and distort color 

information.  

 Steps:  

Step 1: Click Browse… of Multispectral image input to open file; 

Step 2:  The default bands for process is all bands, the band list can be changed by 

choosing with band list button, the number of chosen bands must be more 

than 1; 

Step 3: Click Browse…of high resolution image input to open file; 

Step 4: The default band is the first one, it can be changed by click band list button; 

Step 5: Choose resample method, the default is bilinear interpolation; 

Step 6:  Click Browse… of image output to set the output path, file name and type; 



 

  

Step 7:  Band Description: this edit box is editable and receives the default value. It 

can also add extra image information; the description will be shown in the 

notice of new bands; 

Step 8: Click Run, the main interface disappear and pop up the progress bar. When the 

program finish, the main interface will recover and pop up the dialog of 

success. 

 


